Fork me on GitHub

Mac下cordova+ionic+angularjs做混合移动app开发之--安装环境配置

安装Nodejs:

下载并打开node-v0.12.4.pkg进行安装

更换nodejsnpm包管理器的源:

安装nodejs

1
2
3
4
5
6
#先移除之前的源,因为国内访问比较慢或者访问不了
gem sources --remove https://rubygems.org/
#添加淘宝的镜像源
gem sources -a http://ruby.taobao.org/
#查看一下有没有更新成功
gem sources -l

Mac下Android Studio与Subversion集成的问题

由于Mac10.10下的subversion版本是1.7,而使用smartsvn8.6 checkout版本提示需要upgrade to 1.8
这样一来,使得android studio import 进来的svn项目无法使用集成好的subversion进行管理了,会出现如下错误:

1
2
svn: E155021: This client is too old to work
with the working copy at xxx (format '31')

进过一番搜索得到的解决方法记录如下: